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实验一  影像镶嵌 

一、   实验目的 

由于单幅影像覆盖面积有限，不能满足大范围制图需要，或者不能构成一个

完整的研究区域。为此需要将相邻的单幅影像进行拼接，来满足实际工作中的需

求。从而需要进行影像的镶嵌。 

二、   实验数据介绍 

利用像素进行的影像镶嵌的实验影像数据为：zhangan_dv06_2.img 和

zhangan_dv06_3.img 。 相 应 的 头 文 件 为 ： zhangan_dv06_2.hdr 和

zhangan_dv06_3.hdr。 

利用地理坐标进行的影像镶嵌的实验影像数据为：zhangan_lch_01w.img 和

zhangan_lch_02w.img 。 相 应 的 头 文 件 为 ： zhangan_lch_01w.hdr 和

zhangan_lch_02w.hdr。 

三、   实验过程 

 1. 利用像素进行的影像镶嵌 

在ENVI主菜单中，选择Map →Mosaicking →Pixel Based。出现Pixel Based 

Mosaic 对话框。 

 



  图 1.1  Pixel Based Mosaic 对话框 

从 Pixel Based Mosaic 对话框中，选择 Import →Import files。在 Mosaic 

Input files 对话框中，点击 open，选择文件 zhangan_dv06_2.img 和

zhangan_dv06_3.img。 

 

图 1.2 Mosaic Input files 对话框中 

在 Mosaic Input files 对话框中，同时选中 zhangan_dv06_2.img 和

zhangan_dv06_3.img。点击 ok。在 select Mosaic size 对话框 X size 中输入

614，Y size 中输入 1024，指定镶嵌影像的大小。点击 ok。 

  
图 1.3  select Mosaic size 对话框 

在 Pixel Based Mosaic 对话框中，点击 zhangan_dv06_3.img 文件名。影像

当前的位置就会以像素为单位，行和列在对话框底部的文本框中。在 YO 文本框

中，输入值 513，在键盘上按 enter 键。zhangan_dv06_3.img 文件就放置在了

zhangan_dv06_2.img 文件的下面。 

 



 

图 1.4   镶嵌前 Pixel Based Mosaic 对话框 

 

图 1.5   镶嵌后 Pixel Based Mosaic 对话框 

在 Pixel Based Mosaic 对话框中，选择 file→apply。当 Mosaic parameters



对话框出现后，选择“Memory”，即可生成镶嵌影像。 

 

图 1.6  生成的镶嵌影像 

2. 利用地理坐标进行的影像镶嵌 

打开要进行影像镶嵌的两张图像，在 ENVI 主菜单栏中，选择打开

zhangan_lch_01w.img和zhangan_lch_02w.img文件。选择map →mosaicking →

Georeferenced。出现 map based mosaic 对话框。选择 import →import files。

选中 zhangan_lch_01w.img 和 zhangan_lch_02w.img 文件。 



 

图 1.7   map based mosaic 对话框 

在对话框的下部，有两幅影像的名称，鼠标右键点击＃ 2band1：

zhangan_lch_01w 文件，选择 Edit entry。在 entry 对话框中，在 data value 

ignore 文本框中填入 0，忽略像元背景值，即图像以外黑色的区域。Feathering 

distance 文本框中填入 20，表示在距离边缘线 10个像素的距离处，顶部和底部

的影像都会使用 50％来混合计算输出的镶嵌影像。Color balancing 选择

adjust，点击 ok。 



 

 图 1.8  entry 对话框 

在 map based mosaic 对话框可看到两幅镶嵌的影像。 

 
图 1.9  镶嵌后 Pixel Based Mosaic 对话框 

在 mosaic 对话框中，选择 file→apply。选择“Memory”，即可生成镶嵌影



像。 

 

图 1.10  生成的镶嵌影像 

实验二  影像配准 

一、   实验目的 

学会在 ENVI 中对影像进行地理校正，添加地理坐标，以及如何使用 ENVI

进行影像到影像的配准。主要掌握遥感图像处理中影像校正、配准功能，通过实

验进一步掌握这类处理的理论原理。在本实验中利用 SPOT 影像校正 Landsat TM

影像。 

二、   实验数据介绍 

本次实验的实验数据为利用 SPOT 影像: zhangan_bldr_sp.img 文件和

Landsat TM 影像: zhang_bldr_tm.img 文件。 



三、   实验过程 

1. 打开并显示 SPOT 数据和 Landsat TM 数据 

从ENVI主菜单中，选择file →open image file。打开zhangan_bldr_sp.img

和 zhang_bldr_tm.img 文件。点击 ok。选中 zhangan_bldr_sp.img 文件，点击

Load Band 按钮，加载这幅影像到一个显示窗口中。再选中 zhang_bldr_tm.img

文件。 

点击 display#1 按钮，并从下拉式菜单中选择 new display。点击 Load Band 按

钮，把 TM的 band3 波段的影像加载到一个新的显示窗口中。 

从主影像窗口菜单栏中，选择 tools →Cursor Location/value。在主影像

窗口、滚动窗口和缩放窗口的 TM 影像上，移动鼠标光标。光标位置信息对话框

会显示影像的详细信息。 

 

图 2.1  Cursor Location/value 显示窗口 

2. 开始进行影像配准 

从 ENVI 主菜单栏中，选择 Map →Registration →Select GCPs：Image to 

Image。在 image to Image Registration 对话框中，点击并选择 display＃1，

作为 Base Image。点击 display＃2作为 Warp image。 

 
图 2.2   image to Image Registration 对话框 

点击 ok，启动自动配准程序。通过讲光标放置在两幅影像的相同地物点上，



来添加单独的地面控制点。选择的同名地物点，需要在两张图上都有，一般选择

河流和道路的交叉点或者拐角点。交叉点或拐角点的选择要依据图像空间分辨率

大小来确定。 

启动 Ground control Points Selection 对话框后，首先在两张图上找到同

名地物点，在 SPOT 图像上找到一点，将鼠标移动至该点，同样的方法在 TM影像

上找到该点。在两个 Zoom 窗口中，查看光标所在位置，把十字丝移到对应位置，

记录每点的 X,Y 值。 

 
图 2.3  Zoom[4X]窗口中十字丝 

Ground Control Points Selection 对话框中，点击 Add point，把该地面控

制点添加到列表中。点击 Show list 查看地面控制点列表，依据同样的方式寻找

其余的同名地物点。 

 

图 2.4   Ground control Points Selection 对话框 



 
图 2.5  Show list 列表 

在 show list 对话框中，经选择了 4 个以上的地面控制点后，RMS 误差就会

显示出来。在选择的控制点中，某点的误差很大，删除该点，重新寻找新的点来

代替。在 show list 对话框中用鼠标点击该点，选择 delete 即可删除该点。如

果对所有选择的控制都不满意的话，可以通过 Ground Control Points Selection

对话框，选择 Options →Clear All Points，可以清除掉所有的已选择的地面

控制点。在 Ground control Points Selection 对话框中，选择好的满意的地面

控制点后，在对图像进行校正之前要对控制点信息进行保存。 

  

图 2.6  Zoom 窗口显示地面控制点 

3. 校正影像 

从 Ground Control Points Selection 对话框中，选择 Options →Warp 

Displayed Band。在 Registration Parameters 对话框中的 Warp Method 按钮菜

单中，选择 RST 校正法。在 Resampling 的按钮菜单中选择 Nearest Neighbor

重采样法。选择“Memory” 点击 ok。 



 

图 2.7 Registration Parameters 对话框 

 

图 2.8  RST 校正法的 Nearest Neighbor 重采样后的 TM影像 

使用 RST 校正法，选择 Bilinear 重采样法。方法与上面类似。 



 

图 2.9 Registration Parameters 对话框 

 
图 2.10  RST 校正法的 Bilinear 重采样后的 TM影像 

使用 RST 校正法，选择 Cubic Convolution 重采样法。方法与上面类似。 



 
图 2.11 Registration Parameters 对话框 

 

图 2.12  RST 校正法的 Cubic Convolution 重采样后的 TM影像 

使用 Polynomial 校正法，选择 Cubic Convolution 重采样法。方法与上面

类似。 



 
图 2.13 Registration Parameters 对话框 

 

图 2.14  Polynomial 校正法的 Cubic Convolution 重采样后的 TM影像 

使用 Delaunay 三角网的 Triangulation 校正法，选择 Cubic Convolution

重采样法。方法与上面类似。 



 

图 2.15 Registration Parameters 对话框 

将纠正图像与 SPOT 基图像进行动态链接和动态覆盖，检查纠正的精度。从主

影像窗口菜单中，选择 Tools →Link →Link Displays，然后在对话框中，点

击 ok。 

 

图 2.16  RST 校正法的 Nearest Neighbor 重采样后的 TM影像与 SPOT 影像比较 



 

图 2.17  RST 校正法的 Bilinear 重采样后的 TM影像与 SPOT 基影像比较 

 

 

图 2.18 RST 校正法 Cubic Convolution 重采样 TM影像与 SPOT 基影像比较 



 

图 2.19 Polynomial 校正法 Cubic Convolution 重采样 TM 影像与 SPOT 影像比较 

 

实验三  影像增强处理 

一、    实验目的 

通过使用 ENVI 对 TM 影像数据的处理，掌握 ENVI 的基本操作，同时探究 ENV

的主要功能。实现空间域增强，点运算中的线性变换，非线性变换，直方图均衡

化，直方图规定化，领域运算中的图像锐化，图像平滑。频率域增强中的图像锐

化，图像平滑。彩色增强中为彩色增强和假彩色增强。多图像代数运算中的差值

法、比值法和混合运算法。多光谱图像变换中的主成分变换和缨帽变换的实验操

作。 

二、    实验数据介绍  

使用 TM数据，进行图像增强处理分析。 

三、    实验过程 

1. 色彩增强 

(1) 伪彩色增强 

打开影像，在主影像栏中选择 Tools →Color Mapping →Density Slice„。



将出现 Density Slice Band Choice 对话框，选择文件 TM Band 1，点击 ok。在

Density Slice 对话框中选择 “0 to 9”。点击 Apply。 

 
图 3.1  密度分割过程 

           

图 3.2  伪彩色增强图像 

（2）假彩色增强 

在可用波段列表中，点击 RGB Color，选择 R（4）G（3）B（2）三个波段来

进行波段显示。点击 Load RGB，一幅假彩色图像就显示在影像窗口中。在可用

波段列表中，点击 RGB Color，选择 R（3）G（2）B（1）三个波段来进行波段显

示。在可用波段列表中，点击 Display＃1，在下拉菜单中，选择 New display，

点击 Load RGB，一幅真彩色图像就显示在影像窗口中。动态链接比较前后两幅



影像的效果，在主影像窗口中，选择 tools →link →link displays，在 link 

displays 对话框中，点击 ok，两幅影像就链接起来了。在可用波段列表中，选

择其余的波段组合方式，并加以比较。 

 

图 3.3  不同波段组合间的影像显示效果 

2. 多图像代数运算 

在主菜单栏中，选择 Basic Tools →Band math。将出现 band math 对话框。

在enter an expression的文本框中，输入需要进行波段计算的IDL（Interactive 

Data Language）表达式，使用变量代替波段名或文件名，变量名必须以字符“b”

或“B”开头，后面跟着 5个以内的数字字符。 

 



图 3.4  Band math 对话框 

（1）差值法 

计算两个波段的差值，可以将数学表达式：b1-b2 输入到文本框中，点击 Add 

to list，表达式将添加在对话框中，点击 ok。 

 
图 3.5  差值计算对话框 



 

图 3.6  差值法后图像 

（2）比值法 

计算两个波段的比值，可以将数学表达式：float(b1)/ float(b2)输入到文

本框中，在变量前用浮点型字节来防止计算时出现字节溢出错误，输入有效的表

达式之后，点击 Add to list，表达式将添加在对话框中，点击 ok。 

 



图 3.7  比值计算对话框 

  
图 3.8  比值法后图像 

（3）混合运算法 

计算三个波段的平均值，表达式：（float(b1)+float(b2)+float(b3)）/3

输入到文本框中，点击 Add to list，表达式将添加在对话框中，点击 ok。 

 



图 3.9  混合运算对话框 

 

  图 3.10  混合运算法后图像 

3. 多光谱图像变换 

（1）主成分变换 

在 ENVI 的主菜单选择 Transform →principle compents →Forward PC 

Rotation→Compute New Statistics and Rotate。选择输入文件 zhangan.img，

出现“Forward PC Parameters”对话框，输出统计文件 memory,点击“OK’。 



 

图 3.11  Forward PC Parameters 对话框 

出现“PC EigenValues”窗口。每个节点是 PC各分量的特征值,可进一步计算各

波段信息量大小,通过PC1的方差百分比及PC1中各波段协方差矩阵的特征向量。 

 

图 3.12  PC EigenValues 对话框 



 

图 3.13 主成分变换后图像 

（2）缨帽变换 

在 ENVI 的主菜单选择 Transform →Tasseled Cap。选择输入文件

zhangan.img，出现“Tasseled Cap Transform Parameters”对话框，输出统计

文件 memory,点击“OK”。 

 

图 3.14  “Tasseled Cap Transform Parameters”对话框 



 

图 3.15  缨帽变换后图像 

实验四  非监督分类 

一、   实验目的 

学习遥感影像的非监督分类操作处理，掌握K均值分类法和IsoData分类法。 

二、   实验数据介绍 

    本实验数据为 TM数据，影像名称为：zhangan.img，相应的头文件为：

zhangan.hdr。介绍如下： 

TM1 0.45-0.52um,蓝波段,对水体穿透强,对叶绿素与叶色素反映敏感,有助

于判别水深及水中叶绿素分布以及水中是否有水华。TM2 0.52-0.60um,绿波段,

对健康茂盛植物的反射敏感,对力的穿透力强,用于探测健康植物绿色反射率,按

绿峰反射评价植物的生活状况,区分林型,树种和反映水下特征。 

TM3 0.62-0.69UM ,红波段,叶绿素的主要吸收波段,反映不同植物叶绿素吸

收,植物健康状况,用于区分植物种类与植物覆盖率,其信息量大多为可见光最佳

波段,广泛用于地貌,岩性,土壤,植被,水中泥沙等方面。TM4 0.76-0.96UM 近红

外波段,对绿色植物类别差异最敏感,为植物通用波段,用于牧师调查,作物长势

测量,水域测量。 



TM5 1.55-1.75UM,中红外波段,处于水的吸收波段,一般1.4-1.9UM内反映含

水量,用于土壤湿度植物含水量调查,水分善研究,作物长势分析,从而提高了区

分不同作用长势的能力.易于反映云与雪。TM6 1.04-1.25UM 热红外波段,可以根

据辐射响应的差别,区分农林覆盖长势,差别表层湿度,水体岩石,以及监测与人

类活动有关的热特征,进行热制图。TM7 2.08-3.35UM,中红外波段,为地质学家追

加波段,处于水的强吸收带,水体呈黑色,可用于区分主要岩石类型,岩石的热蚀

度,探测与交代岩石有关的粘土矿物。 

三、   实验过程 

从 ENVI 主菜单中，选择 File →Open Image file，选择 zhangan.img 文件，

点击 ok。在可用波段列表中，选择 RGB Color 单选按钮，然后用鼠标左键，顺

次点击波段 4、波段 5和波段 3。点击 Load RGB 按钮，把该影像加载到显示窗口

中。在主影像窗口对影像进行简单的区分和目视判读工作。 

1. K 均值分类法 

在 ENVI 主菜单中，选择 Classification →Unsupervised →选择 K-means。 

在 Classification Input file 对话框中，选择分类影像和分类波段数，点击

ok。在 K-means parameters 对话框中，确定分类数为 6 类，其余参数采用默认

的方式，选择选择“Memory”，点击 ok，影像进行分类。 

 
图 4.1  Classification Input file 对话框 



 

图 4.2  K-means parameters 对话框 

在可用波段列表中，添加一个新的图像显示窗口，从 Display＃1 下拉菜单

中，选择 New Display。双击 K-Means（zhangan.img）分类图像，分类后的图像

就显示在新的影像窗口中。从主影像窗口菜单中，选择 Tools →Link →Link 

Displays，然后在对话框中，点击 ok。 

 
图 4.3   彩色合成影像与 K-means 分类后影像进行比较 

使用鼠标左键，在影像上点击并拖动动态叠加显示区域，将 K-means 分类结

果同原始的彩色合成影像进行比较。 

2. IsoData 分类法 

在 ENVI 主菜单中，选择 Classification →Unsupervised →IsoData，在



Classification Input file 对话框中，选择分类影像和分类波段数，点击 ok。 

在 IsoData parameters 对话框中，输入 Number of Classes（分类数），Min（最

少分类数）8、Max（最大分类数）15，Maximum Iteration（最大迭代数）10，

Chang Threshold（像元变化的阀值）5.00，Minimum ＃Pixel in Class（每类

中的最小像元数）1，Maximum Class Stdv （最大标准差）3.00，Minimum Class 

Distance （最小类间距）4.00，Maximum ＃Merge Pairs（最大合并数）2 等 8

个基本参数，选择选择“Memory”，点击 ok，影像进行分类。 

 

图 4.4  Classification Input file 对话框 

 

图 4.5  IsoData parameters 对话框 

在可用波段列表中，添加一个新的图像显示窗口，从 Display＃1 下拉菜单

中，选择 New Display。双击 ISODATA（zhangan.img）分类图像，分类后的图像



就显示在新的影像窗口中。从主影像窗口菜单中，选择 Tools →Link →Link 

Displays，然后在对话框中，点击 ok。 

 

图 4.6   彩色合成影像与 IsoData 分类后影像进行比较 

使用鼠标左键，在影像上点击并拖动动态叠加显示区域，将 IsoData 分类结

果同原始的彩色合成影像进行比较。 

按住鼠标左键的同时，再次点击鼠标右键，触发第三幅影像的动态叠加显示。

将 IsoData 分类结果和 K-means 分类结果进行比较。 

 
图 4.7   IsoData 分类后影像与 K-means 分类后影像进行比较 

3. 类别定义和类别合并 

类别定义:在主影像中，选择 Overlay→Classification，选择 ISODATA 分

类结果，在 Interactive Class Tool 面板中，可以选择各个分类结果的显示。 



 
图 4.8   各个分类结果的显示 

Interactive Class Tool对话框中，选择Option->Edit class colors/names。 

通过目视或者其他方式识别分类结果，填写相应的类型名称和颜色。 

 

图 4.9   相应的类型名称和颜色 

类别合并：选择主菜单Classification→Post Classification→Combine 

Classes。把同一类的类别合并成一类。在点“Ok”后，需要选择输出文件和Remove 

Empty Class 选择"YES"，可以得到结果。 



 

图4.10   Combine Classes parameters对话框 

 

 

图 4.10   类别合并后影像 

 

 

 

 

 



实验五  监督分类 

一、   实验目的 

学习遥感影像的监督分类操作处理，对分类后的影像进行相应的后处理。后

处理包括聚合处理，筛选处理、并类处理，以及精度评估。并比较监督分类和非

监督分类后的影像。 

二、   实验数据介绍 

本实验数据为 TM数据，影像名称为：zhangan.img，相应的头文件为：

zhangan.hdr。数据介绍与非监督分类数据一致。 

三、   实验过程 

1.  分类样本的选择和优化 

从 ENVI 主菜单中，选择 File →Open Image file，选择 zhangan.img 文件，

点击 ok。在可用波段列表中，选择 RGB Color 单选按钮，然后用鼠标左键，顺

次点击波段 5、波段 4和波段 3。点击 Load RGB 按钮，把该影像加载到显示窗口

中。从主影像窗口中，选择 Overlay →Region of Interest。接着对应于显示

窗口的 ROI Tool 对话框。 

在 ROI Tool 对话框中，选择 ROI_type 为 polygon，Window 中选择“Zoom”。

然后在主影像窗口中，绘制一个多边形，该多边形就代表了新创建的感兴趣区。

在主影像窗口中，点击鼠标左键，建立感兴趣多边形的第一个点。再次点击鼠标

左键，按顺序选择更多的边线点，点击鼠标右键来闭合该多边形。鼠标中键可以

被用来删除最新定义的点，或者删除已经闭合了的整个多边形。再一次点击鼠标

右键，固定多边形的位置。通过选 ROI Controls 对话框顶部对应的单选按钮，

感兴趣区可以在缩放窗口中被定义。 

感兴趣区域定义完后，它就会在对话框的可用区域列表中显示出来，同时显

示的还有感兴趣区域的名字，颜色以及所包含的像素总数。要定义一个新的感兴

趣区，点击 New Region 按钮。点击 Edit 按钮，在打开的 Edit ROI Parameters

对话框中，可以输入感兴趣的名字，选择感兴趣区的颜色和填充方式。按照上述

步骤，定义新的感兴趣区。对分类影像定义 6 个地类。 



 
图 5.1   感兴趣对话框及样本 

选择 Stats 按钮，计算感兴趣区的统计信息，绘制均值波谱曲线（白色），

均值波谱上下各有一条的标准差曲线（绿色），以及最小和最大值的包络波谱曲

线（红色），其包含了感兴趣区所有的波谱。 

 
图5.2  感兴趣区统计信息 

对训练的样本进行保存，在 ROI Tool 对话框中，选择 file →save ROIs。 

在 Save ROIs to file 对话框中，选择 Select All Items，点击 choose 选择保



存路径和文件名为 zhangan_feilei.roi。点击 ok保存文件。 

 

图 5.3   Save ROIs to file 对话框 

在 ROI Tool 对话框中，选择 Options →Compute ROI Separability。查看

图像分类精度。 

 
图 5.4  ROI Separability Report 对话框 

为了提高图像分类精度，需要对训练样本进行提纯。在 ROI Tool 对话框中，

选择 File →Export ROIs to n-D Visualizer  →n-D Control; n-D Visualizer

让像元在 n维空间内自由转动（可以控制转动速度 Speed），当转到最能区分各



类型训练区像元的位置时，停止转动，进行样本提纯操作。在 n-D Visualizer

窗口中用鼠标选择某类训练区的纯像元并点击鼠标右键确定，再次单击右键→

Export Class，提纯后的训练区将出现在 ROI Tool 窗口中。 

 

图 5.5  n-D Visualizer 窗口 

2. 进行分类 

分类方式包括平行六面体法、最短距离法、马氏距离法、最大似然法、波谱

角分类以及二进制编码法等，选择合适的分类方式。 

选择最小距离法分类，最小距离分类法使用了每个感兴趣区的均值矢量，来

计算每一个未知像元到每一类均值矢量的欧氏距离。除非用户指定了标准差和距

离的阈值，否则所有像元都将分类到感兴趣区中最接近的那一类。 

在 ENVI 主菜单中，选择 classification → supervised → Minimum 

Distance，在 Classification Input File 对话框中，点击选择进行监督分类的

文件 zhangan.img，点击 ok。在 Minimum Distance Parameters 对话框中，选择

Select All Items, set Max stdev from Mean 和 set Max Distance Error 采

用默认的方式。选择“Memory”。在对话框的右边，选择不输出规则图像，在 Output 

Rule Image 上下按钮用鼠标点击一下即可。 



 
图 5.6   Minimum Distance Parameters 对话框 

点击 ok，即可进行最小距离的监督分类，计算结果出现在可用波段列表中。 

在可用波段列表中，添加一个新的图像显示窗口，从 Display＃1 下拉菜单中，

选择 New Display。双击 min Dist（zhangan.img）分类图像，分类后的图像就

显示在新的影像窗口中。 

 



图 5.7   最小距离法分类后的 TM图像 

3. 影像分类后处理 

我们需要对分类后的影像进行处理，评价其分类效果和精度，或者将类概括

出来，并导入到地图影像和矢量 GIS 中。 

分类统计:分类统计主要从被分类图像中，提取统计信息。这些不同的统计

信息可以是基本统计信息、（最小值、最大值、标准差、方差等）、直方图或者是

从每个所选类中计算出的平均波谱。 

选择 classification →post classification →class Statistics，来进

行统计处理。选择分类影像，然后点击 ok。接着选择原始被用来分类的影像

zhangan.img，点击 ok。使用 Class Selection 对话框，来选择要进行统计的类，

点击 Select All Items，然后点击 ok。 

 

图 5.8   Class Selection 对话框 

在 Compute Statistics Parameters 对话框中，选择要计算的统计信息，并

点击 Compute Statistics Parameters 对话框底部的 ok按钮。 



 
图 5.9   Compute Statistics Parameters 对话框 

然后根据所选择的统计选项，几个绘制图和报表会出现在屏幕上。 

 

图 5.10    统计选项绘制图和报表 

混淆矩阵:ENVI 计算混淆矩阵的功能允许对两幅图像（分类影像和真实影

像），或者对分类影像和感兴趣区进行比较。地面真实影像可以是另一幅分类影



像，或者是根据地面真实测量生成的影像。 

选择 Classification →Post Classification →Confusion Matrix →

Using Ground Truth ROIs。使用 Using Ground Truth ROIs 进行混淆矩阵的计

算。在 Classification Input file 对话框中，选择分类后的影像 Memory1.img，

点击 ok。在 Confusion Matrix Parameters 对话框中点击 ok按钮。 

 

图 5.11    Confusion Matrix Parameters 对话框 

查看混淆矩阵和混淆影像。通过使用波谱剖面廓线和 Cursor/Location 

Vlaue，来对分类影像和原始反射率影像中的感兴趣区进行比较，确定误差的来

源。 

  
图 5.12 分类影像混淆矩阵结果 

总体精度由被正确分类的像元总和除以总像元数计算。地表真实图像或地表

真实感兴趣区限定了像元的真正分类。Kappa系数是另外一种计算分类精度的方

法。它是通过所有地表真实分类中的像元总数乘以混淆矩阵对角行的和，再减去

一类中地表真实像元的总和与这一类中被分类的像元总数与所有分类总数的比

的积，再除以总的像元数的平方减去这一类中地表真实像元与这一类被分类的像

元总数的积与所有类的这些因子的比得到的。 

总体精度： Overall Accuracy = (5183/5615)  92.3063%  



Kappa 系数：Kappa Coefficient = 0.8903 

分类图类别试验像元数目 

Class 沙地 林地 耕地 水体 裸地 其它 试验像元数 

沙地 1284 0 0 11 0 0 1295 

林地 0 678 0 53 0 0 731 

耕地 0 0 226 0 0 0 226 

水体 0 30 0 136 160 0 326 

裸地 15 11 0 53 2498 0 2577 

其它 0 89 0 10 0 361 460 

Total 1299 808 226 263 2658 361 5615 

分类图类别试验像元百分比/% 

Class 沙地 林地 耕地 水体 裸地 其它 像元 Total 

沙地 98.85 0.00 0.00 4.18 0.00 0.00 1295 23.06 

林地 0.00 83.91 0.00 20.15 0.00 0.00 731 13.02 

耕地 0.00 0.00 100.00 0.00 0.00 0.00 226 4.02 

水体 0.00 3.71 0.00 51.71 6.02 0.00 326 5.81 

裸地 1.15 1.36 0.00 20.15 93.98 0.00 257 45.89 

其它 0.00 11.01 0.00 3.80 0.00 100.00 460 8.19 

Total 100.00 100.00 100.00 100.00 100.00 100.00 5615 100.00 

 

Class Commission(Percen) Omission(Percent) Commission(Pixels) Omission(Pixels) 

沙地 0.85 1.15 11/1295 15/1299 

林地 7.25 16.09 53/731 130/808 

耕地 0.00 0.00 0/226 0/226 

水体 58.28 48.29 190/326 127/263 

裸地 3.07 6.02 79/2577 160/2658 

其它 21.52 0.00 99/460 0/361 

 

Class Prod. Acc. 

(Percent) 

User Acc. 

(Percent) 

Prod. Acc. 

(Pixels) 

User Acc. 

(Pixels) 

沙地 98.85 99.15 1284/1299 1284/1295 

林地 83.91 92.75 678/808 678/731 

耕地 100.00 100.00 226/226 226/226 

水体 51.71 41.72 136/263 136/326 

裸地 93.98 96.93 2498/2658 2498/2577 

其它 100.00 78.48 361/361 361/460 

 

聚合和筛选处理：要对分类影像进行筛选处理，选择 ENVI 主菜单栏中的

classification →Post classification →sieve classes，再选择分类影像，

并输入到 memory 中，然后点击 ok。 



 

图 5.12 sieve Parameters 对话框 

 

使用输出的筛选处理后的结果，作为聚合处理的输入图像。选择

classification →Post classification →clump classes，选择“Memory2”，

点击 ok。输出到 Memory，点击 Clump Parameters 对话框中的 ok 按钮。比较处

理前后的三幅影像。 

 

图 5.13   处理前后的三幅影像比较 

合并类：选择 ENVI 主菜单栏中的 classification →Post classification 

→combine classes，再选择分类影像,点击 ok。在 combine classification 

parameters 对话框中，选择要进行合并的两类，先选择要被合并的类，再选择

新的输出类，（列如将 unclassified 并入到 bare 地类，组成新的 bare 地类则

Input class 选择 unclassified，Output class 选择 bare）。点击 ok 即可生成

新的合并类。 



 

    图 5.14   Combine Classification Parameters 对话框 

 

图 5.14   合并类后的 TM分类影像 

修改类的颜色：当显示分类影像时，可以通过修改类的颜色，改变特定类所

对应的颜色。在主影像窗口中选择，tools →Color Mapping →Class Color 

Mapping。 



 

图 5.14   Class Color Mapping 对话框 

在 Class Color Mapping 对话框中，点击某个类的名字，并拖动相应的颜色

条，或者输入所需的颜色值，来改变类的颜色，所做的改变就会立刻应用到分类

影像上。要进行永久性的改变，在对话框中，选择 Options→ Save Changes。 

 

实验六  植被盖度提取 

一、   实验目的 

学习通过遥感影像提取植被盖度等信息方法，对 NDVI 和地面调查的植被盖

度，构建模型，反演植被盖度。 

二、   实验数据介绍 

本实验数据为 TM数据，影像名称为：lq_20111.img，相应的头文件为：

lq_20111.hdr。通过 ENVI 生成 NDVI。 

三、   实验过程 

1.  NDVI 生成 

从 ENVI 主菜单中，选择 File →Open Image file，选择 zhangan.img 文件，



点击 ok。在可用波段列表中，选择 RGB Color 单选按钮，然后用鼠标左键，顺

次点击波段 4、波段 3和波段 2。点击 Load RGB 按钮，把该影像加载到显示窗口

中。然后同主菜单中，选择 Transform→NDVI。 

 

图 6.1 确定用于计算 NDVI 的数据文件 

选择 lq_20111.img 文件，点击 ok。弹出 NDVI 计算参数对话框。 

 

图 6.2 NDVI 计算参数 

指定 NDVI 输出路径，然后点击 ok，计算 NDVI。 



 

图 6.3 NDVI 计算过程 

在可操作波段窗口中，选择 NDVI 文件，选中 Gray Scale，点击 Load band。 

 

图 6.4 NDVI 图像 

2.  植被盖度反演 

从 ENVI 主菜单中，选择 Basic Tools →Band Math。弹出 Band Math 对话

框。 



 
图 6.5 Band Math 对话框 

输入通过 NDVI 反演植被盖度的公式，假如植被盖度=0.325NDVI+28，将公

式输入，点击 Add to List，可以将该模型进行保存。然后点击 ok。 

      

图 6.6 指定计算波段 

选择 NDVI，指定植被盖度输出路径及文件名，点击 ok 即可完成植被盖度

数据。结果如下图。 



 

图 6.7 植被盖度数据 

 

实验七  GPS 数据采集 

一、   实验目的 

学习利用手持 GPS 终端，采集控制点及调查点的经纬度数据，并生成点矢量

数据。为遥感图像几何校正和监督分类等提供参考数据。 

二、   实验数据介绍 

本实验使用 GPS 手持终端，采集并通过 ArcGIS 生成点数据。 

三、   实验过程 

1.  控制点的采集 

若采集的点主要是用于遥感图像校正，首先找到遥感影像上易于识别的点，

通过 GPS 进行该点实际经纬度数据的采集。比如像十字路口、大型建筑物的拐点、

桥梁、河流与道路交点等等，这些点易于识别。 



2.  调查点的采集 

针对要利用遥感数据反演植被盖度，通过 GPS 记录植被盖度调查样地、样方

的经纬度。 

 

  
图 7.1 手持式 GPS 

 

图 7.2 调查数据 

 



实验八  ArcGIS 软件使用与制图 

一、   实验目的 

学习 ArcGIS 软件的使用，学会通过该软件，掌握基于 GPS 点的矢量文件的

生成。学会植被盖度等专题数据的制作。 

二、   实验数据介绍 

植被盖度数据和 GPS 野外采集到的点数据。 

三、   实验过程 

1.  点的生成 

将Excel中的点数据(Lat,Lon)转换为Shape文件(point)的方法  

（1）点击ArcGIS中的 按钮，添加数据；选择“Data-XY.xlsx”数据文件，点击Add按钮添加

数据到ArcGIS中。  

 

图8.1 选择Excel数据文件 



 

图8.2 选择Excel文件中的数据表XY_Data$ 

点击Add添加表格数据到ArcGIS软件中： 

（2）在Layers图层栏，选择导入的数据表，点击鼠标右键，选择“Data”-“Export…”，将Excel

表格保存为*.dbf文件； 

 

图8.3 将加载的数据表另存为dbf文件 



 

图8.4 保存对话框 

点击“OK”，导出*dbf格式的文件。  

这时在ArcGIS中弹出对话框窗口，询问是否要将 “Export_Output.dbf”文件导入到ArcGIS

视图中，选择“yes”（确定）。 

 

图8.5 是否加载到ArcGIS中 

（3）将上面生成的*.dbf文件在ArcGIS中显示出来，并导出为Shape文件。  

选择Layers栏中的*.dbf文件，点击鼠标右键，选择“Display XY Data…”——选择XY属性列

——选择坐标系统——“OK”。  



点击Layers中生成的图层，点击右键，选择“Data”——“Export…”即可导出shape文件。  

如下图所示： 

 

图8.6 显示XY数据 

 
图8.7 Display XY Data对话框 

选择坐标系统(也可由已有的shape文件指定)： 



 

图8.8 指定投影 

选择“Select”——在弹出的坐标系统选择对话框中选择“World”-“WGS 1984”；  

也可以选择“Import…”——在弹出的窗口中选择已有的Shape文件(要有*.prj文件)。  

点击“应用”——“确定”——“OK”。  



 

图8.9 生成的点数据图层 

在显示ArcGIS中显示XY点数据，并注意有一个图层“Export_Ouput Events”产生。点击

“OK”，这样就生成了一个点Shape文件。 

2.  制图与输出 

(1) 加载专题数据 

打开ArcMap，→然后点击工具栏中的add data按钮，→选择要制图的数据。

如图8.10所示。 

 

图8.10 加载数据 

（2）页面设置 

点击view菜单中的Layout view，→单击文件菜单中的page and print setup，根



据情况选择纸张和纵向、横向，这里设置为纵向。 

（3）地图制图和整饰的要素 

通过Insert菜单，添加Title、Text、Legend、North Arrow、Scale Bar等信息，

在图上点击右键，选择Properties，进行边界样式等整饰。如图8.11所示。 

    

图8.11 整饰 

（5）预览和打印输出 

完成制图后，点击文件菜单，进行保存，也可以通过文件菜单中的Export map

导出TIFF等格式的图片文件。 

 

图8.12 植被盖度分布图 

 


